FC6 und Suspend-to-disk und Acer Travelmate 661

Ich habe es endlich (zugegeben, vorher nie intensiv probiert…) geschafft, suspend to disk auf meinem Acer Travelmate 661 LCi unter Fedora Core 6 zum Laufen zu kriegen. Im Nachhinein war es gaaaanz einfach…

  1. Füge

    [atrpms]
    name=Fedora Core $releasever – $basearch – ATrpms
    baseurl=http://dl.atrpms.net/fc$releasever-$basearch/atrpms/stable

    zur yum.conf bzw. als Datei in /etc/yum.repos.d hinzu

  2. installiere
    • hibernate-suspend2
    • kernel-suspend2-2.6.18-1.2849_1.fc6.cubbi_suspend2

    Die Kernelversion kann sich natürlich ändern, außerdem sollten alle zugehörigen Module installiert werden

  3. Ändert in der /etc/hibernate/hibernate.conf die Zeile

    SuspendDevice swap:/dev/EuerSwapDevice

  4. Editiert die /etc/grub.conf:

    kernel /vmlinuz-2.6.18-1.2849_1.fc6.cubbi_suspend2 ro root=/dev/VolGroup00/RootVol000 resume2=/dev/EuerSwapDevice quiet

  5. Fügt in /etc/hibernate/common.conf hinzu:

    OnResume 20 /usr/sbin/855resolution 4d 1400 1050

  6. Startet einmal neu und bootet den suspend-kernel

Diese „Anleitung“ ist kein HowTo und kein Handbuch, nur eine kurze schriftliche Niederlegung meiner Schritte, damit andere und auch ich etwas zum Nachlesen haben.

Mein Dank geht vor allem an diese Seite, mit deren Hilfe ich das 1400×1050-Auflösungs-Problem behoben habe.

FC6 und wpa_supplicant

Ich habe mich heute mit der Frage beschäftigt, warum mein FC6, welches ich von FC5 aktualisiert habe, nicht richtig mit WLANs zusammenarbeiten wollte. Es war nicht mehr möglich, mit dem NetworkManager einfach ein WLAN auszuwählen und sich dann zu verbinden. In der /var/log/messages gab es immer Fehler mit wpa_supplicant. Die Erleuchtung kam mir dann eher per Zufall: Es war noch ein wpa_supplicant-Paket von den ATRPMs installiert:

Removing:
wpa_supplicant i386 1:0.4.9-13.fc5.at installed

Dadurch kam es also zu den Unstimmigkeiten. Bei einem einfachen yum update wurde das Paket übrigens nicht aktualisiert. Also schnell ein yum remove wpa_supplicant und dann ein yum install NetworkManager, das hat’s dann geholfen und jetzt habe ich

wpa_supplicant i386 1:0.4.9-1.fc6

installiert. Alles läuft. Juhu.